menuMENU    UK Free TV logo Help!

 

 

Click to see updates

How do I change the RF output channel on a Sky Digibox?

How do I change the RF output channel on a Sky Digibox?

How do I change the RF output channel on a Sky Digibox?
published on UK Free TV

Press the [SERVICES] button and then press [4] [0] [1] then [SELECT]



Then press [4] to go to the RF output menu.



You can now change the value so that it does not clash with an analogue TV channel or a Freeview multiplex.

HD and "new EPG" boxes

If you have a HD box, press [SERVICES] button and then press [0] [0] [1] then [SELECT]. Nothing is shown on the TV screen until you press the Select button.

Then use the [RIGHT] arrow button on the remote until this screen is shown, and press SELECT to change the values:



All questions
Removing all barriers to communication between diverse cultures1
How do I get a test card with Freeview2
What can I do when my Sky Digibox says 'No Signal' or 'Technical fau3
Can I receive UK TV in Ghana?4
I would like to know if it is possible to receive UK terrestrial Freeview servic5
[][][
In this section
Can I use my ex-contract sky digital satellite receiver to get Freeview channels1
What can I do when my Sky Digibox says 'No Signal' or 'Technical fau2
Can I stop paying Sky and use my satellite receiver to get Freeview ?3
I have a Panasonic TV with integrated Freeview how can I record Freeview channel4
My Sky box has a "no signal message" - what do I do?5
I have split the signal from my satellite dish and now nothing works.6

Comments
Sunday, 14 September 2014
N
Nigel Pardoe
9:23 AM

Hi. Thank goodness there are folk on this thread that seem to know what they're talking about. I have sky hd box in the children's playroom downstairs and magic eye upstairs. I bought an io link to get an rf2 feed, bought another io link with psu as I thought that was the problem. Bought another magic eye as I thought that was the problem, now I'm making my way through resetting the default 68 from ch21-68. I'm still not getting a light on the magic eye. Plugged it in direct to io link and it works fine/light comes on. Reseated connectors at both ends. I get the channel but can't change over as the light on the magic eye will not illuminate ... Help please before I chuck the whole bloody thing out the window! I'm systematically starting from 21 this afternoon...

link to this comment
Nigel Pardoe's 3 posts GB
J
jb38
sentiment_very_satisfiedPlatinum

10:03 AM

Nigel Pardoe: Although having reseated the connectors at both ends of the cable, is said cable continuous? or does it go through anything such as a distribution amplifier?, because should this apply then any device that the signal is being fed through has to be of the "DC pass" variety so as "not" to block the 5 / 9 volts from the modulator that operates the magic eye.

Just out of curiosity, is there any particular reason for you changing the default channel output from the RF modulator?

Further advice dependant on feedback.



link to this comment
jb38's 7,179 posts GB
Monday, 15 September 2014
N
Nigel
9:29 AM

Thanks JB. Continuous cable. Feedback from this and other sites suggest ch68 default would not work, further suggesting a default change to a 30-40rang and a retune. I am currently retuning ch35, but to no avail. What is odd, is that when the io link came o plugged in and the magic eye worked fine, but for some unknown reason the light went out a week ago and I can't get it back. Any further advice greatly appreciated. If I can't do it myself I'll have to pay for sky to come back as the real reason the children have a sky hd box in their room is so I can watch sports/films in bed when they're in bed!!!

link to this comment
Nigel's 3 posts GB
Tuesday, 16 September 2014
J
jb38
sentiment_very_satisfiedPlatinum

12:22 AM

Nigel : Thanks for the update, however the content of insomuch that the magic eye had previously been working but for no apparent reason had stopped doing so, somewhat changes the situation, as my reply was "not" based on having knowledge of this fact, likewise it was assumed that you had purchased a second eye (with PSU) because you were unable to get the first one to work.

However, if the magic eye illuminates perfectly OK when its plugged directly into the I.O modulators output, but "not" when its connected to the other end of the coax cable from the RF modulators output, then this can only be caused by (1) a "DC" short circuit (not RF) on the cable, or (2) by a voltage drop occurring along the length of the cable, this being something which is not the norm "if" the cable is continuous as the power required to illuminate the eye is extremely low, and although you might be using the additional power supply, this is basically to increase the strength of the "signal" to enable the box to be controlled over an extended length of coax cable and "not" for the light.

If you personally installed the coax between the two locations and have any cable left, then temporarily fit a couple of coax connectors onto the cable and use this to test if the eye still operates with a length of cable between the I.O. port and the eye.

By the way, on the subject of Ch68, there is no reason whatsoever why Ch68 cannot be used, as many use this channel including myself, the 60's (at least from 62) being a safer range to use as nothing transmits in this frequency range, hence the analogue signal from the I.O. modulator is reasonably safe from being interfered with by another transmitter.

This of course, is "only" applicable if you are feeding the DTT signal into the I.O's aerial socket to enable Freeview to be viewed upstairs as well as the programme on the Sky box, if not, then it doesn't matter what channel is used.

I do have to say, that many people experience problems using Sky links, as they can be a tad erratic in their operation, especially so where SKy+HD boxes are concerned, numerous complaints having been made by owners of these devices when they were first released concerning non-operation of the Sky link control system, and so its possible that your problem might be caused by the box having a low output.

Two questions : (1) Have you double checked that the RF sockets power is definitely switched on. (2) Do you possess a "simple" DC voltmeter that can also measure low value resistance?

link to this comment
jb38's 7,179 posts GB
N
Nigel
4:43 AM

jb38: thanks for taking the time and trouble to post a comprehensive reply. Problem now solved, new F connectors fitted both ends, io link with psu, magic eye once again illuminated. It seems a strand of the copper cable caused a short. Thanks again, N.

link to this comment
Nigel's 3 posts GB
J
jb38
sentiment_very_satisfiedPlatinum

11:49 PM

Nigel: Once again thanks for the update, pleased to know that the problem has now been rectified by replacing the "F" connectors, a stray strand of wire coming into contact with the centre core of the coax being a relatively easy mistake to make due to the wire being so fine.

link to this comment
jb38's 7,179 posts GB
Friday, 19 September 2014
P
Peter B
5:34 PM

Great job, thanks a lot. Working a treat. Brilliant, fabulous , magic, I'd have your kids if I was female lol
T

link to this comment
Peter B's 1 post GB
Saturday, 1 November 2014
S
Steve
11:34 AM

Hi,

Was wondering if anyone could help with my issue tha is driving me crazy!?!? Any suggestions would be most welcome.

I recently moved house, and inthe old house I had a magic eye fitted upstairs to allow me to watch and change channels from the 2nd tv. I simply had a coax cable running from the RF2 to the magic eye on the 2nd tv and all worked perfectly.

Since moving I have run another coax cable for the same setup, but it will not work!?!? The red LED does not come on, although I get a picture on the 2nd tv. I have switched the RF2 setting off, rebooted and switched back on again, and still no joy. I've plugged the magic eye directly into the back of the box and still no red light. I've tried 2 more magic eyes and still the same.

Does anyone have the answer?

My cousin even tested the RF2 output and he said he was getting 9v from it, so I can't understand why its not lighting up?

Please help!

link to this comment
Steve's 1 post GB
J
jb38
sentiment_very_satisfiedPlatinum

12:35 PM

Steve: If both of the additional magic eyes are known to be working, and that they were definitely tried in the Sky boxes RF2 socket and not accidentally in RF1, then the fault must be with the box, because even although your cousin may well have seen 9 volts being indicated on his meter, the reading could well have dropped to zero as soon the eye was connected into the socket, as its not exactly unknown for a voltage regulator to develop a problem whereby it fails on load.

You should get your cousin to prise open one of the magic eyes and measure the voltage whilst its plugged into the RF2.


link to this comment
jb38's 7,179 posts GB
Thursday, 13 November 2014
E
E M Philip
8:36 AM
Banchory

during the last week my sky program on 505 CNBC has been either off or badly distorted. All other channels work perfectly although occasionally channel502 Bloomberg has also been unstable.Last night at 7PM it did work for some time perfectly but no signal again this morning. Ellis Philip Inchmarlo AB31 4AF

link to this comment
E M Philip's 1 post GB
Select more comments

Your comment please
Please post a question, answer or commentUK Free TV is here to help people. If you are rude or disrespectful all of your posts will be deleted and you will be banned.







Privacy policy: UK Free Privacy policy.